Download Wallet!Get the latest version of Ethereum Mist Wallet Here!

AMD Sapphire Nitro+ RX 580 8GB Limited Edition Mining Rig Tutorial – 190 Mh/s

Ledger Wallet protects your bitcoins

Here is another mining rig, this time i am using the new Sapphire Nitro+ RX 580 8GB Limited Edition GPUs. I must say that this is one of the best mining rig i ever build, it worked with no crashes or any other issues from the beginning, it is like a plug and play machine, power up and forget about it πŸ™‚

As you can see for this mining rig i use dual PSU, not because of high power consumption or anything related to that, since with this crypto mining rush is very hard to find other components too not only GPUs.. so i was looking to get EVGA 1300w PSU or any 1300w 80+ Gold certified PSU and i ended up with 2x EVGA 750w πŸ™‚ which works great!

Hashrate results: Ethereum 190 Mh/s + Siacoin 3,230 Mh/s

Let’s get started!

Hardware used

To receive the latest updates follow me on social media! πŸ™‚
facebook
twitter
google
youtube

1 Step 1 – Hardware Installation

If this is your first time assembling a PC, check this tutorial: Tutorial: Ethereum Mining Rig Part 3 (building the rig)

A) Motherboard – connect the following parts
  • CPU and Cooler
  • Memory RAM
  • SSD
  • Power Button

B) PSU – connect cables and dual psu adapter
  • PSU 1: 3x VGA Cables, 3x SATA Cables, 1x Motherboard 24 Pin Cable, 1x CPU Cable, 1x Molex Cable
  • PSU 1: Connect 1x Motherboard 24 Pin and 1x CPU Cables to motherboard
  • PSU2: 3x VGA Cables, 3x SATA Cables, 1x Motherboard 24 Pin Cable
  • Dual PSU Adapter: Connect Molex cable to ADD2PSU adapter from PSU 1 and then attach the Motherboard 24 Pin Cable to ADD2PSU from PSU 2
C) GPU and USB Risers
  • 1x GPU
  • 1x USB Risers
  • First connect 1x USB Riser cables (USB 3.0, 6 PIN to SATA) , then connect it with SATA cable from PSU 1, plug USB 3.0 in to 16x PCIe slot
  • Attach the GPU to USB riser and then connect it with 8 Pin (only) VGA cable
2 Step 2 – Windows installation, Drivers and Mining Tweaks

3 Step 3 – GPU BIOS mod/flash & tools

4 Step 4 – Power up the rig with all 6 GPUs

5 Step 5 – How to power up the rig with two PSUs

  • Connect both PSUs power cables to wall plug
  • PSU 2: Turn it on by switching the button from 0 to 1
  • PSU 1: Turn it on by switching the button from 0 to 1
  • Press power button to start the PC, both PSUs will start almost at the same time
  • When windows is booted wait for few minutes to discover all 6 GPUs, you can check in device manager when all GPUs are installed

Before to continue further, please share this πŸ™‚ thanks!

6 Step 6 – Claymore Dual Ethereum Miner

  • Download Claymore: https://mega.nz/#F!O4YA2JgD!n2b4iSHQDruEsYUvTQP5_w
  • Extract archive contents on desktop
  • If you want to mine Ethereum only, create a new text document like ETH.txt and paste the following code: EthDcrMiner64.exe -epool eu1.ethermine.org:4444 -ewal <Your_Ethereum_Address>.<RigName> -epsw x -dcri 1 , then rename ETH.txt to ETH.bat
  • For dual mining Ethereum + Siacoin create a new text document and name it ETH+SIA.txt and add the following code: EthDcrMiner64.exe -epool eu1-etc.ethermine.org:4444 -ewal <Your_Ethereum_Address>.<RigName> -epsw x -dpool stratum+tcp://sia-eu1.nanopool.org:7777 -dwal <Your_Siacoin_Address>.<RigName> -dcoin sia -dcri 14,19 or 30
  • for more details on how setup the miner or how to mine ZCash and Monero check this guide: http://1stminingrig.com/best-bios-rom-sapphire-nitro-rx-580-8gb-limited-edition-hynix-memory-31-5-mhs/

The results!

  • Ethereum hashrate 190 Mh/s
  • Siacoin hashrate 3,200 Mh/s
  • GPU clock 1200 (claymore line: -cclock 1200)
  • GPU memory clock 2250 (claymore line:Β  -cclock 1200)
  • Undervolt claymore line -cvddc 850 -mvddc 850
  • Full line: EthDcrMiner64.exe -epool eu1-etc.ethermine.org:4444 -ewal <Your_Ethereum_Address>.<RigName> -epsw x -dpool stratum+tcp://sia-eu1.nanopool.org:7777 -dwal <Your_Siacoin_Address>.<RigName> -dcoin sia -dcri 30 -cclock 1200 -mclock 2250 -cvddc 850 -mvddc 850
  • Power draw 1020w (PSU 1 519w & PSU 2 504w)

have fun! πŸ™‚

Thank you for reading. As always, your comments, suggestions and questions are welcome.

Subscribe and stay tuned for further updates!

Found this useful? Buy me a beer πŸ™‚

PayPal: https://www.paypal.me/1stMiningRig

ETH: 0x8a159cc27454130ee4880504f4d2afe2ebb22d15

BTC: 3DWC5xaaapSRmccAvv12dF3nsRYqx3Y1YM

ZEC: t1T9dLLM14Jh6NNuCPfNsRgGnj58LkT3yYX

  • Awesome speeds!

  • Sani Alindog

    connect it with 8 Pin (only) VGA cable..why 8pin only? is it ok?

    • yep.. check images..

      • Sani Alindog

        whats the use of 6 pin?

  • Tran Nguyen

    Please check my image. I always connect PERIF1 https://uploads.disquscdn.com/images/ac2472cddbd3b2c3ef43c41e99e5f887ddd62ec8cee73b18e34d396bb7504edc.jpg Cable to 2 lots on image. is it necessary?

    • no when using powered risers.

      • Tran Nguyen

        Thanks. I will remove it. It was connected without problem πŸ™‚

  • Yeroslav

    What is the difference between the regular RX 580 cards and the limited adition? I have 6 REGULAR AMD SAPPHIRE NITRO+ RX 580 8GB MINING RIG , this guide will fit them as well? or I should change something?

  • Yeroslav

    What do you guys think it worth the most to mine today with the 6 RX 580 cards mining rig?

  • mikem

    Great write ups and a great resource for novice and expert. I was wondering if you could clarify something in your write up?

    GPU clock 1200 (claymore line: -cclock 12o0)
    GPU memory clock 2250 (claymore line: -cclock 1200)
    Undervolt claymore line -cvddc 850 -mvddc 850
    -cclock 12o0 -cclock 1200 -cvddc 850 -mvddc 850

    I am using triXX but would like the adjustments to be made in Claymore. I am using the settings 1150 /2150 and -100mV on my Nitro+ 580’S 4GB and getting 30.5.

    Why do you use an “o” instead of a zero (0) ? why are there 2 cclock settings? and do voltage settings always match?

    Any help is most appreciated.

    • Hi, yes sorry about that.. i just edited the miss typed text.. not really sure how i missed that πŸ™

  • Alexander Stephani

    hey

    is there an issue in your post by the claymore lines:

    GPU clock 1200 (claymore line: -cclock 1200)

    GPU memory clock 2250 (claymore line: -cclock 1200)

    should this at memory clock not be mclock ?

    greetz Alex

    ps i ordered today the special edition too but its completely blue with blue led fans πŸ˜‰

    hope it works together with my 2 x rx 470 nitro+

    • Alexander Stephani

      and on mclock fill in 2250 not 1200 or ?

      when I’m wrong sorry for that

      • Yes, sorry :/ didn’t noticed it.. i just changed it now.. thanks!

  • Popescu Catalin

    Hello
    Unfortunately i have this GPU available to buy .
    It is alright to be used in this configuration you have done?

    1)HIS Radeon RX 580 IceQ XΒ² OC, 8GB GDDR5, DVI, HDMI, 3x DisplayPort
    2)Gigabyte Aorus Radeon RX 580 XTR 8G, 8GB GDDR5, DVI, HDMI, 3x DisplayPort

    I would appreciate your help to decide .

  • Trikol

    So this is the best setup right now for ETH/ETC? If so then im starting to build it

  • Jay

    What version of windows did you use? Tia

  • @ciprianpt:disqus Are you also writing here, or are they just copying(stealing) ? LINK REMOVED …. some of their articles seem very very similar to yours?

    • Yep, they just steal my work :/ will check that and will try to report them.. thanks! πŸ™ they use spinning software for synonyms..

      • I’m not sure if they can remove comments from Disqus, but we could start making references there to the original articles here … I would be happy to do that once in a while πŸ™‚

        • They can moderate the comments and delete or ban by ip.. but we can try that πŸ™‚

  • Yeroslav

    Hi, I have another question:
    – I have this HX1200i CORSAIR power supply, will it be good for this RX580 6 cards gear?

    • Umm will be at its limit, you will have to make a good undervolt, ill sugest a 1300w psu or two of 750w

  • Alexander Stephani

    hey there,

    ive bought 4 of the sapphire rx 580 limited edition but another edition the gpu’s are completely blue with blue led fans

    on completely standard i only get 19 mh per card is that normal and can i do this tut for this graphic cards too ?

    greetz alex

    • I guess you have the special edition not the limited edition πŸ˜€

      • Alexander Stephani

        Ok πŸ˜‰
        Can i do this tutorial for my GPU s too ?

        • Don’t think so.. you better edit their original bios..

          • JuSx3

            I used the bios provided in the tutorial to flash a nitro+ rx580 special edition hynix memory and it went from 19mh/s to 27.5mh/s. But I am not having any luck with the clocking when i use claymore -cclock 1200 -mclock 2250 -cvddc 850 -mvddc 850 the system crashes I tried clocking with msi afterburner 1130/2250 -96mV and it is stable but gives me just 1 mh/s more. Any suggestions?

          • JuSx3

            *Update: Just got very stable 29.8/9mh/s with -cclock 1200 -mclock 2210 -cvddc 850 -mvddc 850 but again would appreciate suggestions :). Will try to edit the original bios on one of my other cards and will get back with results and if it made any difference.
            *Update2: I moded the silent bios by copying both 1:1750 to 1:2000 and 2:1750 to 2:2000 and it was a disaster I got just 20mh/s with the same clocks in claymore as above.

          • Hi, maybe there is one card that cant handle the undervolt.. try to change -cvddc 850 -mvddc 850 to -cvddc 875 -mvddc 875 or -cvddc 850 -mvddc 875… also add -wd 0 to see which card is crashing and mining with 0.00 Mh/s

          • JuSx3

            I was actually testing on one card at a time and this behavior was common to all of them. I will try what you suggested. Also one out of the 6 cards gets the driver to crash and then freezes and I am testing the rig with the other 5 and it runs stable at 29.8mh/s could this possibly be solved by decreasing the undervolt?

          • Onzar

            I have the same cards. What is your best setting?

          • JuSx3

            cclock 1200 mclock 2210 voltages at 875 all set in claymore. Are you currently getting 30.3, I was getting 30.5 with increased DCRI in claymore but at the current epoch I am only getting 175 MH/s, waiting for the new AMD drives that should be fixing this.

          • Onzar

            What is your power consumption in GPU-Z and wall???

          • JuSx3

            It is 76w in GPU-Z and about 120w per card from wall for total of 870w and it actually is cclock 1210 mclock 2210. my hashrate dropped dropped to 172.3 at epoch 139 I still haven’t applied the new drivers but I will do it tomorrow to see how to power usage increases.

          • JuSx3

            I installed the new amd beta driver and i got to 185MH/s from 172MH/s eth only mining. My setting are 1130 core clock, 2210 memory clock, 850 voltages for both memory and core, 880 watts power consumption. I used the AMD wattman for tweaking.

          • JuSx3

            I tried 1200/2250 875/875 with the five cards on and it crashed again.

          • JuSx3

            You are the man brother it runs stable at 1210/2210 875/875 with all the six cards at 30,1mh/s. Do you think I can play a bit more and increase the clocks and maybe the voltage a little bit for more hash rate. I am using 1200w seasonic PSU for which I’ve read people are running stable at 1400w draw, GPUZ shows about 80w draw per card. Or maybe keep all the cards at 850/850 and only the problematic one at 875/875. However you saved the day!!!

          • Hey.. yeah you can play with the settings.. have you tested the gpus one by one ?

          • JuSx3

            Yeah, I spent hours testing and the final results i could get were:
            1300/2210 no undevolt 30.7-8mh/s
            1230/2210 875/875 30.5mh/s 80w in GPUz – currently mining seems stable.

            I couldn’t squeeze more out of those cards. Anything above 2210 memory clock doesn’t seem to improve the hashrate after that value increasing the core clock increases it.

            *Update one of the cards just crashed certainly the one that doesn’t handle the undervolt very well. I will try to set this one only to 885/885. For GPU 4 the value format would be -cvvdc 875,875,875,885,875,875 right?

  • Ti

    Hi again, guys!
    Maybe some of you had already noticed that hashrate is slowly decreases as epoch increases.

    You can read info about it here:
    http://www.legitreviews.com/ethereum-hashrate-performance-drop-might-coming-amd-nvidia-gpus-tested_195702

    Share your experience. Maybe some of you already found solution (before AMD)?

    Regards.

  • Muhammad Bilal Javaid

    HI There,
    I am creating a rig with GPU Nvidia 1080 Ti there will be overall 6 graphics cards right now and i will mine Ethereum. Please help me out. Am I on righ track? Thanks

    • Yep, 1080 Ti are very good πŸ™‚

      • Muhammad Bilal Javaid

        Thanks Mate <3

  • JasonX

    Hi @ci@ciprianpt:disqus

    bought this new Sapphire Nitro+ RX 580 8GB from newegg last week w/ Hynix memory. unexpectedly, i only got 22Mhs stock whereas i am expecting 24-25stock on this GPU..

    Brand Details: Sapphire Radeon NITRO+ RX 580 8GB GDDR5 PCI-E Dual HDMI / DVI-D / Dual DP w/ backplate (UEFI)
    Model: 100411NT+8GL

    tried to OC it using 1150 CC / 2150 mem but i could only reach 26Mhs stable rate. whenever i push the mem clock to 2200, the GPU crashes using Claymore 9.6

    i copied strap 1:1750-> 1:2000 and 2:1750-> 2:2000 & 2250

    some say the GPU might get brick if i push this GPU further. any idea or suggestion so i can maximize this GPU’s performance…

    • Hi, try copying the 2: only… that stands for Hynix mem.. let me know!

  • Robert Gzivna

    Hello guys, maybe i was lucky enough but i found settings for Gigabyte RX 580 Gaming 8G / GV-RX580GAMING-8GD
    what i did:

    replace 1750/2000/2250 with this timings (value is from this Ciprians BIOS from this post).

    777000000000000022AA1C00B56A6D46C0551017BE8E060C006AE6000C081420EA8900AB030000001B162C31C0313F17

    then flash bios, apply clock patch. reboot.
    i used original utility from gigabyte, its name is gigabyte aeorus…

    so i started claymore with default values and started modify the aeorus tool. i was able to have stable core 1150/ mem 2150(2200 gave me artifacts so i cho https://uploads.disquscdn.com/images/80019c4c179e5c78c3f5c9ea9152b4ac1d8dd873f1a90885618bae4367dd14a3.jpg sed just for sure safer 2150 instad of 2175) and mining at speed of 29,6Mhs. tested aprox 1hour and no problem

    so enjoy,hope it helps, becvause i was struggling with gigabyte a LOT!

    btw thank you Ciprian for timings:) U saved lot of folks out there:)

    P.S. any recommendation for dual mining ethereum + LBRY?

    • Good job there πŸ™‚ i prefer siacoin or decred…

    • Brock Huffaker

      I followed the same steps in the OC post. I also applied the changes Ti suggested to undervolt. My issue is that one card works just fine and hashes around 31Mh/s. Once I plug in 2 cards the system is really unreliable. One card hashes at 4Mh/s and the other around 29-30. Any idea on why it would do that. Both cards hash stable at 30-31+ by themselves in each of the 1×16 slots but when both plugged in I get crashes and one hashes at 4. I have been trying to get my rig up for a few days now and would greatly appreciate some help. I would be more than happy to toss some ETH your way if you can assist. I’m using RX580 8GB Nitro+ Hynix cards on Asus z270-P board. My GTX 1070 rig was a walk in the park compared to this guy πŸ™‚

      • Robert Gzivna

        dont know if it helps you, but here is what i did:
        1. instal windows only with one card in pcie then update windows to the latest version.
        2. save bios, modify bios as above (copy paste that timings into 1750,2000,2250)
        3. use ddu, remove driver,change card, repeat step 2 with card 2,3,4,xxx.
        4. use ddu, turn off pc, turn on all cards, instal driver
        5. open amd radeon driver tool in tool bar, go to gaming tab, top right click “add” and browse. search for your exe file in claymore folder click open. it will create new settings tab in radeon software. then click on second tab something like wattman. for each card change core frequency to dynamic and voltage control to manual.
        use what you want but i enden stable on stage 6/7 with 1200mhz/1000mV and for frequency 2250mhz. click apply. this will automaticaly load this profile when you open claymore. so you dont need to put any settings for cards into calymore *bat file. anyway i had stabilty issue when i used settings into claymore bat file. yo dont need any other tool.

        i am curently having core/mem/voltage 1200/2250/1000mV, stable with 30/30,5Mhs (2cards only so far), gpu-Z shows 105W for each card, stable for two days.
        btw each card is different and they dont have same hasrate, difference is 0,5Mhs on same settings. first is worst and it gave “only” 29,9-30,1 and secornd is giving 30,3 all the time.

        so hope it helps

        • Brock Huffaker

          Which driver version are you using? I read 17.4.3 is the best.

          • Robert Gzivna

            dont know if 17.4.3 is the best, i am using the latest one 17.7.1 downloaded from official amd.com site

          • Brock Huffaker

            Thx for the info. I tried following and I get around 30Mh/s for each but it reboots ever few minutes or graphics crash. Another weird thing is that GPU1 doesn’t show any temp or fan readings in claymore. I’m going to keep at this. I’ll post back what I find.

          • Robert Gzivna

            i recommend you start with 1150/2150 and test for stability. then increas mem with 25Mhz steps and test again till you find stable frequency. btw use HWINFO for mem errors. if you get any, drop frequency.
            on 1125(50)/2150/925mV you should be ok with 29Mhs and 90W. try& and let me know

          • Brock Huffaker

            Hey guys I think it was the under-volting that was getting me crashes. I re-flashed the bios on my two cards back to stock and then only changed the mem strap as suggested above. I would still get crashes If I set clocks to core1200/mem2250. I tried just leaving them at the standard values and still was crashing. I then tried core1150/mem2150 and was stable but I could not get the temp readings to show in Claymore for the 2nd GPU. I just think there are some crazy driver issues with windows 10 right now. I downloaded SimpleMininOS. So far I’m running 30 minutes without crash, hashing just over 29Mh/s and 586Mh/s SC. I have the SMOS OC set at core1150/mem2150 Power Stage 7. I am okay running this now but once I hook up all 8 GPUs this thing is going to suck power. Why I was under-volting the cards were pulling about 100W. Now they pull about 180W. Currently 2 GPUs in my rig from the wall is pulling 500W. I’m a novice when it comes to under volting GPUs. How can I get the power usage down? If I wanted to undervolt but just not as extreme as @disqus_8LuuwzNkwH:disqus shows above what would that look like? Thanks again for all the help!
            http://i.imgur.com/ekp5M5M.png

          • Robert Gzivna

            you can undervolt as much as you want in temrs what gpu allows you and stay stable. you can try going down from 1000mV to 800 with 25mV steps. test for half hour if stable and no hashrate drops often, you should be fine.then you can start increasing mem/core but as i said use hwinfo and watch for mem errors if there are any. also be aware that dual mining increase power consumption, so it could be related.

          • Brock Huffaker

            https://uploads.disquscdn.com/images/f9fad7a83f022964f08dda2f57a3bac00d1ad131c003f401c76aafe742ed0331.png https://uploads.disquscdn.com/images/9c4fd9f58707ce6edc3a2b1efe7506b022535e92e8068c9f26a307fa7e51eac5.png
            You can see the differences here. The strange thing is that I made the undervolt changes but when I run a backup of the modded bios they are not reflected. Are these undervoltings recommended. Or should I leave stock like my bios shows and undervolt using Trixx or some other software type mod?

          • Robert Gzivna

            these strings represent “stage” in radeon software- wattman stage 1-7, you can play with it if you like, howver as i said above, i did all changes directly in readeon software, no tools/software are not needed. see how mine looked like, i dont have the latest version yet:)
            now im using 1200/2250/1000mV – 105W in gpu-z and i recommend you to use 950-1000mV for all stages 3-7.

            https://uploads.disquscdn.com/images/74abff2068ec3ee50d594ca27354dbef7688a03a6406f2b91f485f5d93e6e246.jpg

          • Brock Huffaker

            I would use that software but I can’t get more than 1 GPU to run in Windows. The second I add GPU #2 they system is glitchy or GPU2 Mines at like 4Mh/s. I have 2 running somewhat stable for over a day right now using SMOS (no undervolting). I just have a question. Is it normal in Claymore to get this occasionally. I would say I get it about once every few hours. I have tried dropping the clock on GPU0 by 75Mhz but still get it occationally. https://uploads.disquscdn.com/images/03cc05473d3981d7f6694165edf78aad7a9ce5c2c835649e8c513dd7a653b21b.png

          • Robert Gzivna

            Have you tried using hwinfo and watching for mem errors?? If you get mem errors it may cause rejected shares and of course drops in hashrate.
            And each gpu is differend in term of quality…count with it, one can give more and be stable, second give less. So you can st core/mem diferently for each gpu or set less for all gpu’s. Unfortunately im still waiting for more cards to deliver,curently have two only so i cant advise you how to make it run all 6 in W10,however Ciprian has good article somewhere around, check for it.

          • Brock Huffaker

            I can’t even get 2 running in Windows at the moment so can’t really use any software. Currently running simple mining os. When I run just one card in Windows I have zero OC issues at the suggested numbers above. But Once I plug in 2 everything changes.

          • Have you edited the bios like that ?

  • Kianvash Ghahari

    Hi there, would someone be noob friendly and tell me how to modify bios or miner setup to get the best hashpower? Im really noob and beginner and I cant find a post to explain step by step on what to do, please help me guys
    I want to use dwarfpool not the one which is used in this post

      • Kianvash Ghahari

        Thanks you Ciprian
        Look, I want to get my first mining rig with 6x asus strix 570s 8gb (because DAG is getting heavy for 4gb)

        I have to put about 3000$ for that because Im in Iran and no access to ebay or Amazon(and only asus strix is in stock here). And I should borrow thr money from my dad and give it back in 6-7 months.

        I need to know is it possible? Can I get my money back in that time.
        What coins can I mine with it to reach my 3000$?
        Because they say eth might go pos and no mining possible after that, are there any alternatives?

        I really like starting to mine but Im totally begginer in it

        Would you please tell me how to use claymore miner with dwarfpool? Because I heard etherpool is solo and my rig wont be good to get solo shares.

        Help me please.

  • JP

    Hi! Total noob at this. Why do you not use all the power supply pins on the GPUs? I see some open ones in your pictures…

    • JuSx3

      If you are asking for the two molex ones on the PRO BTC H81 they should be plugged in if you are using unpowered risers. He is using powered raiser which draw power from the PSU and not from the MOBO. However I also use powered raisers but I choose to have them plugged in.

  • Wow, anyone following the cryptocurrency bloodbath these days?
    I guess profitability is looking really sad these days

  • Rodrigo Rodrigues

    Can you tell me the frame dimensions using 2 psu ?

  • gunnersbury

    How many GPU’s did you use to get 190mh/s?

    • 6 πŸ™‚

      • gunnersbury

        If I have 6 of the following GPU’s will I achieve 190mh/s?

        Radeon RX 470 MINING Edition 8192MB GDDR5 PCI-Express Graphics Card

        2048 Stream Processors, 1236MHz Boost Clock, 7000Mbs Memory Clocks, 8GB GDDR5.

      • Rodrigo

        Dear @Ciprian V. I bought 6x Sapphire RX570 OC 8GB Hynix for my mining rig, I tried many ways to mod bios of this cards but no results, with or without mods no more than 21mh/s in ETH. Can you giveme a little help?

        https://mega.nz/#F!0E1igYya!s7afm9NBqz60hrE5hYo8wQ

  • gunnersbury

    Also can the setup above be used to mine litecoin?

  • That PSU is not available atm in my country. Can it be replaced by other 750w 80+ psu like CORSAIR RMX SERIES 750W MODULAR 80Plus GOLD? Will the Dual PSU Adapter work with that PSU?

  • RiDD

    Hi, I follow this guide with (Sapphire Radeon NITRO+ RX 570 4GB) and I have a mistake, if I leave in bios (use gpu board) I have problems with (atiflash: error reading from rom) and GPU-Z don’t detect GPUClock and Memory Clock, same as this
    https://www.techpowerup.com/forums/threads/gpu-z-1-18-0-cpu-core-clock-0-memory-clock-0-cpu-temp.232171/

    If I set in bios (pci gpu) and connect HDMI cable to Sapphire GPU, then atiflash and GPU-Z works fine, but when I try to set (OC) with SapphireTrixx my screen goes black..

    Any suggestion? some bios changes? wrong drivers?

    Thanks!

    UPDATE: With (use gpu board) if I connect remotely with my laptop, then I can use GPU-z and AtiFlash… I Investigate a little more, any help will be welcomed!!

  • Brian Nocenti

    I’m wondering why you only used the 8 pin power connector on your vid cards and why you didn’t put the 8 + 6 on them.

    • not needed.. extra power consumption for nothing…

  • Cnd

    Hi Ciprian,

    Will you add a tutorial for rx580 special edition 8g? ( 11265-21-20G )

    It has higher stock values which can help us to get more hash.

    • Hey, those cards were not sold across Europe.. can’t get one to test.. only if you ship that to me, once tested ill can send it back πŸ™‚

      • Cnd

        Hey, shipping fee can make a bomb effect on me πŸ™‚ so what about sending you the original rom for editing? πŸ™‚

        • I’ll suport shipping costs πŸ™‚ email me the rom..

    • Onzar

      I have rx580 special edition 8g ( 11265-21-20G ) my max is 30.3 MH/s in 4xGPU have in wall 640W GPU-Z 100W any have better?

      • Rishi Mishra

        Hi, I have the same card RX 580 Special Edition 8G (11265 – 21 -41G) but getting only 18Mh/s. Any suggestions?

        • Onzar

          Hi,
          first you must mod bios!

          • Rishi Mishra

            thx . modded the bios. installed the AMD beta driver and getting 174 on eth and 3000 on sia using 6 claymore 9.8. 125W per GPU

          • Andrew Furtas

            11265-21-20G What type of memory?

          • Onzar

            Hynix memory πŸ˜‰

      • Rik Rok

        can you please share your bois? which bois are you using? because i can not get it more than 29.5Mh πŸ™

  • Azrael_404

    Hi Ciprian, good article ! Now mining edition gpu have been announced , do you think we should wait and buy them day 1 or still continue with “gaming” gpu ?

    • I’ll gonwith the mining edition ones

  • Mariusz Machnio

    Hi Ciprian, very good article. My rig is based on your’s and it’s working quite fine. I’m a bit confused only. You wrote “Attach the GPU to USB riser and then connect it with 8 Pin (only) VGA cable” for mentioned above GPU card. I have connected my GPU (Sapphire Nitro+ RX580 8GB Hynix) with 8pin plug and 6 pin plug too. Does it mean I can unplug 6pin cable and power GPU with 8pin only? Does it mean I can use free 6pin plug comes from PSU to power riser with 6pin socket?

    • Yes, you can unplug the 6 pin cable.. πŸ™‚

  • Tony Woodside

    My rig has 6x AMD R9 290X GPU’s and I’m getting 196 MH/s (32.7 MH/s per card). I have my cclock =1170 and mclock= 1100. Try those numbers out on your rig and see what hashrate you get.

    • ZeroCool

      Hello,

      getting 33.3 + 1030dcr on my non x 290
      try 1181cc & 1430mc

      what is your watt intake per gpu ?

  • Tony Woodside
  • Goran Ergic

    Hello Ciprian, I already bought 12x Sapphire Nitro+ RX 580 8gb, I am going to setup my first rig with 6x GPU. So now I need to buy other components. What you think about following parts:

    Mobo: ASUS PRIME Z270-A
    CPU: Intel Pentium Processor G4400 3.3 GHz
    PSU: 1200w
    RAM memory: 8gb

    Or do you have any suggestion?
    Thanks

    • Hey @goranergic:disqus m rx 500 consume a little more power than rx 400s, ill suggest 1300w PSU or two of 750w. As for the motherboard, that should be good, why not h81 pro btc ? 4gb rams are enough πŸ™‚

      • Goran Ergic

        Hi tnx for answer. Power supplier now is 1500w πŸ™‚
        About motherboard I really dont know why I didn’t take h81. I found a lot of suggestions for both motherboards. But anyway I have 12 cards so for second rig I will do with h81.
        This is off topic: Does anyone know about S9 Antminer how to setup? Some video or something?
        Thanks πŸ™‚

    • Evgeni Enchev

      Hi i am looking to buy a sapphire radeon rx 580 nitro+ limited edition 8192mb Please if you give me more information from where to buy them Thanks epenchev.enchev@gmail.com

  • unichiduci

    Hey guys,
    I can only find AMD SAPPHIRE NITRO+ RX 580 8GB (not Limited Edition). Could you please tell me if the Limited Edition makes any difference? Should I wait or buy the “simple” ones?
    Thanks!

  • hp_miner

    Hi Ciprian,
    Do you have any idea for Gigabyte Aorus RX580 8GB Hynix mem? I am not able to get past 29.0 to 29.3 Mh/s per card. Kindly help!

  • Ben Weinberg

    Hi. Will this guide be ok to follow for the ASUS RX 580 4GB OC cards?

  • rjdeeeee

    Hi Ciprian,
    Does this work for Sapphire Nitro RX 570 8GB running on Windows 8.1?

  • sdharbinger

    Hi Ciprian

    What sort of weekly return are you getting on this rig?

  • somali

    Hey Ciprian,
    Thanks for feedback and replies. Could you please reply a few if you dont mind.

    1/ Please share the BIOS.
    2/ You are not using Limited Editions RX580?
    3/ How did you specify ‘Undervolt claymore line -cvddc 850 -mvddc 850’ since my TRIXX wont work.
    4/ I have 4 cards at ~31MHz or above (1350MHz n 2250MHz) and power requirement around 890w. Something is very wrong somewhere. (I was planning to plug in 6 cards (since you quoted 1100watts, so I bought Corsair 1200i), Now with 4 clocking at 890, I dare not to plug another 1.

    Help required.

    Thanks

    • Hi,

      1/ Bios is already shared πŸ™‚
      2/ what do you mean ?
      3/ You can undervolt directly from .bat file with claymore miner
      4/ For 500s ill recommend 1300w or 2x 750w PSU

  • EthernalyIT

    hi, currently each card do 25MH/s. I don’t understand what’s wrong.

  • ed

    Hi

    Greetings ! Thank you for the guideline . I am planning to build a mining rig using sapphire rx580 and try to follow your step here. I have a question on the gpu to psu connector, in your setup from the gpu to the psu you only connect the 8 pin connector , while this card has 8+6 pin. In what i am aware of if the card has both 8 and 6 pin you need to plug both and connect to psu. Can you share the reason why in this setup you only connect the 8 pin but not the 6 pin ?

    Much appreciated.

    • Hey @disqus_4AyYHCzM1E:disqus , since gpu core is not helping that much with hashrate the extra power is not needed at all, usually those are underclocked a lot like from 1400 to 1130 or 1150 and then undervolted. You can connect the 6 pin if you have enough cables but it wont be needed at all..

join my weekly subscription & get exclusive tips.
Subscribe

Subscribe To My Newsletter For
Latets Tutorials & Updates! Thanks!

Be a part of our subscription and stay updated with the latest trends.
Subscribe Me!
No Thanks!

GIVEAWAY

12 USB Risers + Mining Rig Frame
JOIN NOW
* Terms & Conditions Apply

Send this to a friend